New V2 controller

This topic contains 18 replies, has 6 voices, and was last updated by  Benb 5 months, 4 weeks ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #1659
    Triple D
    Triple D
    Participant

    V2 controller kit of parts arrived, well packaged, quality item. Time to get the soldering iron up to temperature…..

    #1663
    RC Tractor Guy
    RC Tractor Guy
    Keymaster

    Excellent I’m glad it arrived in good condition, I’ve been told I sent 3 1k resistors instead of 4. Sorry about this mistake, any 1k resistor will work if you have one but if not R4 and R5 are only used with XBee or similar device so if you aren’t using an XBee then you can leave one of those off.

    #1686
    AWtruck
    AWtruck
    Participant

    I have the kit and all PCB’s received, and after a night of soldering a beautiful RC controller. All function works, however, I have a question about the Tool to test the NRF2401L. If I do this, there are only zeros in the display, is this correct?

    #1687
    RC Tractor Guy
    RC Tractor Guy
    Keymaster

    The variant value should be a 1 for an nRF24L01+ or 0 for nRF24L01 I think.
    The data rate is suppose to be 1 for 250kbps, RF24_1MBPS for 1Mbps and RF24_2MBPS for 2Mbps.
    The PA level is supposed to be the level in dBm.

    When I test mine I get 1 0 1 so I think the first value is right but the others don’t make sense to me, I possibly have the variable I store the second and third values in defined wrong and they are appearing strangely as a result but I think the first one should be correct.

    #1698
    AWtruck
    AWtruck
    Participant

    I can still link no vehicle with the RC controller. The symbol when the reception level, to the left of the designation for the supply voltage, is with me completely full even if no vehicle is turned on. What can be the problem (I have also tried several NRF modules).

    #1699
    RC Tractor Guy
    RC Tractor Guy
    Keymaster

    The signal indicator indicates how long since you last received a reply from the vehicle you have chosen so it shouldn’t be full unless there is a vehicle there and it matches the ID you selected. It is full when you first select the vehicle but should quickly start to disappear as it fails to get responses. I looked more into the NRF test program and it was working correctly you shouldn’t have all zeros because we set the PA level to 1 elsewhere in the code. How are you powering the controller? The USB on the Meduino doesn’t power the NRF in case you were just using that. Also when you select a vehicle can you see the needles move as you move the joysticks?

    #1700

    Nishitoku
    Participant

    When I choose a vehicle on the controller, the the JD9560R for example, the signal indicator is initially on full. Even if there is no vehicle active. The signal indicator then decays until its just the white dot.
    As i understand it, this is the normal behavior.
    When there is an active vehicle the indicator still decays. There is a connection in the first second, when turning on the vehicle. I can turn on the indicators or the headlights. But after that, everything is dead.

    Thats a bit of a strange behavior. I would expect no connetion at all or some kind of packet loss, but not an initial connection lasting for 1 second.

    I have no idea yet how to debug that.

    #1701
    AWtruck
    AWtruck
    Participant

    I use the battery power of the RC controller. If I select a vehicle the needles are moving of the speed indication.

    #1702
    RC Tractor Guy
    RC Tractor Guy
    Keymaster

    Nishitoku

    The indicator decaying away is correct with no vehicle because it is basically counting the failed responses so initially there are no failed responses and the indicator is full. I should change this to start with a large number of failed responses so that the indicator is empty and when a connection is made it will fill.

    The 1 second of response is very strange, I haven’t experienced anything like that. Maybe the power supply in the vehicle is struggling to continually supply the NRF with smooth power. Maybe adding a 10uF capacitor to the power pins of the NRF would help or maybe lowering the data rate would be easier on the power supply. I’m not sure.

    AWtruck

    That all sounds good. Have you tested more than one NRF and all are reading 000? Are you sure the NRF is getting 3.3V on its power pins?

    #1705
    RC Tractor Guy
    RC Tractor Guy
    Keymaster

    I updated the NRF test tool in a new library so now it should run a sequence of tests by sending commands to change NRF setting and then testing the response from the NRF to confirm the settings have changed. It should be very clear now if the NRF is working/connected or not.

    Here is the new library http://rctractorguy.com/wp-content/uploads/2016/05/RCTractorControllerV2-2.zip

    #1713

    Nishitoku
    Participant

    I build a test configuration only with the pro mini, the NRF24+ module and 1 LED connected to pin 3 of the arduino. For testing purposes i use the JD9560R code, because its only 1 Arduine instead of cab and body.

    I switch on the breadboard – LED is off
    Then i switch on the controller and choose JD9560R in the menu. – LED is still off. The onboard LED on the pro mini though (indicating the connection, i guess) went dimm.
    Then i switch on all lights on the controller (headlights, worklights, full beam) and reset the mini pro. – LED is ON.
    Then i switch off all lights on the controller and reset the mini pro. – LED is OFF again.
    This is repeatable, so there is a kind of connection at the start of the mini pro.

    I also played with the datarate and the transmission power, but when i change anything of that there is no connection at all.
    A 10 nF capacitor had also no effect.

    My vehicles run with the basic controller (old code without RCTractor Libraries and the old Massey code on 2 mini pro)
    I tried to upgrade to the new code for the basic controller and new massey code but i there also loose connection.

    It seems there is something wrong with the newer Library code and my NRF24+ modules. Ikeep you up to date if i find something. 🙂

    #1715
    RC Tractor Guy
    RC Tractor Guy
    Keymaster

    That is very strange. You the NRF on JD9560R and Massey 8680 are wired differently so code wouldn’t be directly interchangeable.

    Massey: RF24 radio(8,10);
    JD: RF24 radio(9, 10);

    I added a new tool to the vehicle library over the weekend, it will run the same NRF test as the controller except it outputs to the serial monitor as there is no screen. Maybe that will at least tell you the library is functioning.

    #1716

    Nishitoku
    Participant

    Yes i took the different wiering into account.
    I started today with a basic test program to send a ping from the controller to the vehicle baord and it worked. So the wiring and the hardware is fine:-)

    I had a look at the test in the vehicle library!
    It says Match in all 4 cases. So its all good on that side.
    I think the link to the newest version 1.05 is broken.
    It looks like http://rctractorguy.com/wp-content/uploads/2016/05/RCTractorGuy.ziphttp://rctractorguy.com/wp-content/uploads/2016/05/RCTractorGuy-1.zip

    • This reply was modified 1 year, 5 months ago by  Nishitoku.
    #1721
    RC Tractor Guy
    RC Tractor Guy
    Keymaster

    Thanks for letting me know about the link.

    That’s good news that all the tests say the wiring is perfect but why the code isn’t working for you is a mystery to me. Are there any warnings from the IDE when you upload the vehicle code, if there are maybe copy them and post them here. Maybe another library is interfering for some reason or maybe we’ll see something else that could be our problem.

    A simple test to rule out the libraries interfering would be before starting the IDE open the libraries folder and cut and paste all the libraries except mine temporarily to another folder. Then open the IDE and upload the vehicle code and controller code.

    What version of the IDE are you using by the way? I’m using 1.6.6 maybe there is something in that.

    #1724

    Nishitoku
    Participant

    I purged the library folder and reinstalled your librarys. Uploaded them on the controller and the Fend939 with the Massey cap and body arduinos.

    Everything works now! Modell battery indicator, the signal indicator, lights, motor(on full, L1 and L2). PERFECT.

    I have to adjust the steering range though, as the tires touch the front hydraulics on full left or right.

    Thanks so much for the suggestion to try a clean library install. I should have done this from the beginning. There must have been some includes the linker took from elsewhere.

    I am using the 1.6.8 IDE

    So now i can add so much more functions to my models. Btw. Is the Syma S107 Code working? I have one of those. I only have to find the power cable 🙂

    Thanks again for your help!

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.